相关文章

思科IOS漏洞影响Rockwell多款工业交换机

来源网址:http://www.ysdtx.cn/

E安全4月20日讯 Rockwell Automation 公司本周向其客户发出通报称,由于受思科 IOS 软件漏洞的影响,其 Allen-Bradley Stratix 以及 ArmorStratix 工业交换机可能易受远程攻击活动入侵。

8项漏洞影响交换机安全

被广泛应用于关键制造、能源以及其它领域的 Allen-Bradley Stratix 以及 ArmorStratix 交换机产品,依靠思科 IOS 软件实现与企业网络的安全集成。Rockwell Automation 公司确认思科 IOS 软件当中最近发现的8项安全缺陷亦会对其产品造成影响。

本文源自E安全

受影响的版本

根据 Rockwell 以及 ICS-CERT 发布的声明,运行有 15.2(6)E0a 及更早版本固件的 Stratix 5400、5410、5700、8000 以及ArmorStratix 5700 交换机会受到危险以及高危安全漏洞的影响,这些漏洞可被远程利用,无需身份验证,攻击者就可以发起拒绝服务(简称DoS)或任意代码执行攻击。

思科智能安装功能当中存在的一项严重远程代码执行漏洞CVE-2018-0171(CVSS 评分9.8分),攻击者可远程向 TCP 4786 端口发送恶意数据包,触发目标设备的栈溢出漏洞造成设备拒绝服务(DoS)或远程执行任意代码,进而全面控制目标设备。

过去几年当中,国家支持型黑客等组织发起的众多攻击活动曾先后滥用智能安装协议。Rockwell 公司已经发布了其固件的 15.2(6)E1 版本,以解决上述交换机当中存在的各项安全漏洞。

另外,Rockwell 公司通知使用 Allen-Bradley Stratix 5900 服务路由器的客户,在 15.6.3M1 及之前全部版本设备都可能被此次披露的四项思科 IOS 漏洞所影响。

然而,Rockwell 方面并未为这款服务路由器提供固件更新,而只是向用户提供了几条缓解建议,另外,该公司表示固件版本为15.2(4a)以及更早版本的 Allen-Bradley Stratix 8300 工业管理以太网交换机会受到8项思科 IOS 软件缺陷影响,同样也只提供了缓解措施说明。

注:本文由E安全编译报道,转载请注明原文地址